(Ps4)Infinite load screen every time I try to leave Colorado Springs

If you need assistance with a technical issue, this forum is for you. Spoilers are allowed, but spoiler warning tags are recommended.
Post Reply
Posts: 1
Joined: January 18th, 2022, 9:45 pm

So I just bought the game from the PlayStation store along with the dlc because it was on sale. I just turned in the garden quest for daisy and now she is sending me into little Vegas. Every time I try to enter the load screen sticks at 30% and won’t go further. I’ve tried creating a save, loading the save and sane issue.

I tried going back to ranger hq, then back to C Springs, and the issue is still there. This last tone the hotel quest popped up and I get the infinite load bullshit trying to enter the hotel too. It seems this game is just horribly broken and I can’t even play it now. Should I just request a refund or is there a fix?

Edit: it won’t load anything from Colorado Springs other than HQ. I left he and tried to rescue the convoy and same infinite load. I tried removing companion and the same issue.

As a last ditch effort I created a whole new game and started from a scratch and as soon as I do that first mission for daisy I get stuck. I get the infinite load loop and can’t play further. At this point I’m beyond frustrated, the game is unplayable and it’s looking like requesting a refund from Sony is my only option

Edit 2: so one last effort. I uninstalled and reinstalled the game and now it won’t even load and freezes loading any save file.
User avatar
Posts: 399
Joined: November 18th, 2019, 11:56 am
badge image for 4o80c0.png

Looks like we're working with you via the support portal on this one.
Post Reply

Return to “Wasteland 3: Technical Help”