Crash with AMD GPU

If you need assistance with a technical is sue with The Bard's Tale IV, this forum is for you. Spoilers are allowed, but spoiler warning tags are recommended.

Moderator: Bard Hall Bouncers

Post Reply
frabron
Acolyte
Posts: 70
Joined: December 16th, 2013, 1:08 am
Location: Schland

Crash with AMD GPU

Post by frabron » December 20th, 2019, 6:50 am

Hi everybody,

I recently upgraded to a RADEON 5700 XT graphics card, and with it came the new AMD Adrenaline Version 19.122. Since then I cannot run Bard's Tale IV anymore, it just crashes before displaying anything. The sceen goes black after starting the game and after a few seconds the windows 10 desktop reappears. Along with the crash comes an entry in the event viewer which output is shown below:

Code: Select all

Name der fehlerhaften Anwendung: BardsTale4-Win64-Shipping.exe, Version: 4.20.1.0, Zeitstempel: 0x5dd4122e
Name des fehlerhaften Moduls: ATIDXX64.DLL, Version: 26.20.15002.61, Zeitstempel: 0x5de85dcc
Ausnahmecode: 0xc0000005
Fehleroffset: 0x0000000000b61417
ID des fehlerhaften Prozesses: 0x2fc4
Startzeit der fehlerhaften Anwendung: 0x01d5b7436ce5304f
Pfad der fehlerhaften Anwendung: C:\GOG\The Bard's Tale IV Director's Cut\BardsTale4\Binaries\Win64\BardsTale4-Win64-Shipping.exe
Pfad des fehlerhaften Moduls: C:\Windows\System32\DriverStore\FileRepository\u0349781.inf_amd64_a9a51f30a2be0d77\B349558\ATIDXX64.DLL
Berichtskennung: 081ccc2b-560f-46a1-b5bc-05fddc270d80
are there any know issues with the new Radeon 5700 xt or the latest AMD drivers?

frabron
Acolyte
Posts: 70
Joined: December 16th, 2013, 1:08 am
Location: Schland

Re: Crash with AMD GPU

Post by frabron » December 23rd, 2019, 2:26 am

I used the Radeon 19.12.3 drivers, reverting back to 19.11.3 makes the game run again. Apparently AMD broke something with their new Adrenaline 2020 drivers here.

eisberg
Scholar
Posts: 189
Joined: August 14th, 2018, 2:51 pm

Re: Crash with AMD GPU

Post by eisberg » December 26th, 2019, 1:42 pm

Yup, I get the same problem. AMD broke something in the drivers, again.

Honestly, I think this is the last time I will ever buy an AMD card, I guess fourth time is the charm.

First Radeon, I had all kinds of problems that took them years to fix.

Radeon 9700 Pro, many problems with games, again, took them a long time to fix

Radeon 7850, many problems with games, again, took them a long time to fix.

and now RX 5700 XT, having problems with this game, and some other games that I never had a problem with before when I had Nvidia.

I had Nvidia graphic cards between all those Radeon cards, and I never ever had a single problem with any game when using Nvidia. But now I am stuck with this AMD card for next 3 years, and I am going back to Nvidia to never ever return to AMD.

waltc
Scholar
Posts: 223
Joined: July 1st, 2015, 11:51 am

Re: Crash with AMD GPU

Post by waltc » December 28th, 2019, 2:56 pm

@ eisberg Funny, as I've been running ATi/AMD since 2002 and owned the GPUs you mentioned and quite enjoyed them. No problems such as you relate. Indeed, R300, or the 9700 Pro, absolutely crushed anything nVidia had in play at the time--in fact, they had nothing even comparable at the time and it took nVidia ~2 years to catch up....;) Last nVidia card I owned was a GTX 8800, IIRC. I did not buy any more...;)

@Fabron: I'm having the same problem with the DC; however, the original game, if you still have it installed, works just fine with the 19.12.3's, so go figure...;) Be sure and report this to AMD--I'll do that myself! Here's my hardware/OS, if that helps. This is the first game I've run with the 19.12.3's that simply refuses to open.

Windows10x64 v1909, build 18363.535
Latest Adrenalins--19.12.3
AMD 50th Anniversary 5700XT
Aorus Master x570 UEFI bios F11
Corsair HX-850 PSU (72a x1 12v rail)
AMD Ryzen 5 3600X @ 3.8Ghz & boost
RAM 16GB 2x8GB, Patriot Viper Elite PV416G320C6K @3200mhz 16 16 16 36 1T @ 3733Mhz 18-19-19-19-38-68 1T
LG MultiDrive DVD writer SATA
Boot: Samsung 960 EVO NVMe 250GB (UEFI boot partition)
2x 1TB WD Blue 7200 rpm S3
ST2000DM S3 2TB
ST4000DM004 S3 4TB
BenQ EW-3270U 4k, HDR10 monitor

shmerl
Explorer
Posts: 355
Joined: September 28th, 2014, 6:31 pm

Re: Crash with AMD GPU

Post by shmerl » December 31st, 2019, 9:13 pm

For what it's worth, it works well now on Linux with AMD (RX 5700XT).

waltc
Scholar
Posts: 223
Joined: July 1st, 2015, 11:51 am

Re: Crash with AMD GPU

Post by waltc » January 2nd, 2020, 12:49 pm

shmerl wrote:
December 31st, 2019, 9:13 pm
For what it's worth, it works well now on Linux with AMD (RX 5700XT).
Thanks...just for fun and curiosity I'm reinstalling Update2--want to see if that works with the new drivers.

waltc
Scholar
Posts: 223
Joined: July 1st, 2015, 11:51 am

Re: Crash with AMD GPU

Post by waltc » January 2nd, 2020, 1:23 pm

Ok--well, the 19.12.3's don't work with update 2, either! So, I'm going to reinstall Update 3 and wait on the fix!


For my Gog Galaxy install, to go from update 1 to Update 2 took a 22GB patch. To go from Update 2 to Update 3 took only a 1.2 GB patch...;)

waltc
Scholar
Posts: 223
Joined: July 1st, 2015, 11:51 am

Re: Crash with AMD GPU

Post by waltc » January 10th, 2020, 7:03 pm

Just updated to the 20.1.1 adrenalins--still no go--I let AMD know about this driver version, too!

waltc
Scholar
Posts: 223
Joined: July 1st, 2015, 11:51 am

Re: Crash with AMD GPU

Post by waltc » January 15th, 2020, 1:59 pm

OKay--Good news--the 20.1.2 drivers fixed the problem the new drivers had opening Unreal 4-engine games and the BT4DC is once again running fine! Also, those drivers include the Vulkan upgrade to 1.2...!

IRONCLADLOU
Initiate
Posts: 1
Joined: October 3rd, 2014, 8:56 am

Re: Crash with AMD GPU

Post by IRONCLADLOU » January 15th, 2020, 8:21 pm

I can confirm. 20.1.2 drivers work for the Windows Store version and my Radeon RX 5700 XT.

frabron
Acolyte
Posts: 70
Joined: December 16th, 2013, 1:08 am
Location: Schland

Re: Crash with AMD GPU

Post by frabron » January 16th, 2020, 12:06 pm

That's good to read, thanks for posting the update :)

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests