[MAC] performance issue on Big Sur

Forum for reporting Bugs in the PC version of Wasteland 3. Please refer to our stickied Bug Forum guidelines before posting.
Post Reply
adamr11
Initiate
Posts: 1
Joined: April 4th, 2021, 12:53 am

Hi,

do you know about any performance issue with macbook pro/osx?

It's very slow on my machine:
- MacBook Pro (16-inch, 2019)
- processor: 2,4 GHz 8-Core Intel Core i9
- memory: 64 GB 2667 MHz DDR4
- Graphics:
AMD Radeon Pro 5500M 8 GB
Intel UHD Graphics 630 1536 MB
- OS: Big Sur 11.2.3

Even on the lowest settings, it's laggy and slow.
I own the steam version.

Please, let me know if you have any solution for this problem, because I don't think it's acceptable that this macbook can't run the game properly.

I've already checked the forums, and tried several solution, but none of them worked.

Thanks,
Adam
peanutbutterspice
Initiate
Posts: 1
Joined: May 11th, 2021, 4:10 pm

Yeah, unfortunately, I don't think this one is game related.

I've got the same machine, with the exact same specs believe it or not. I spent a great deal of time debugging the problem and the simple answer, as unfortunate as it is, is the GPU is simply pulling too many watts.

If you use monitoring tools, you'll notice that when the game is running, your CPU will under clock heavily. Mine was running at 1 GHz, sometimes even less. It obviously wasn't thermals since the CPU was running quite cool (65 C, or thereabouts). If you use Activity Monitor to see your GPU usage, you'll also notice that your GPU is being severely underutilized (Go to your menu bar w/ activity monitor open -> Window -> GPU History). Basically, your GPU can't run flat out because your CPU can't provide it with frames to render. On the flip side, your CPU is under clocking itself simply because overall system power can't meet the power requirements of both the CPU and the GPU at the same time. Bit of a catch 22, unfortunately. Once you quit the game and your GPU is no longer being used, your CPU will begin to run at normal frequencies.

The problem happens across all games as well. Noticed severe stuttering and lag in PoE due to the exact same problem. The only fix was to nab an eGPU enclosure. Dropped a 5700 XT in it and now my CPU runs at normal frequencies (and games no longer hitch, stutter, and have severe performance problems).

Not the answer you wanted to hear, for sure. Is what it is though.
Last edited by peanutbutterspice on May 11th, 2021, 4:21 pm, edited 1 time in total.
Post Reply

Return to “Wasteland 3: PC Bug Report Forum”