Page 1 of 1

Game Freezes on PS4

Posted: January 28th, 2021, 8:02 am
by BulldawgTGR
I've been trying to play this game on PS4 since September. The only way I've gotten it to load without freezing is to not update it at all. I'm sorry but playing a game where everyone's name is xxxxxx is ridiculous, why can I not play this game since patch 1.14? It freezes on the very first loading screen everytime. Also I would've returned this game already if it wasn't a gift.

Game Freezes at Startup - PS4

Posted: January 28th, 2021, 3:44 pm
by Mattonomicon
I've replied in two of your previous threads where this was reported. I went ahead and amended the title to help attract attention from anyone else who also might be experiencing this. Being that this isn't being reported by a number of others, and has affected you for awhile, it's difficult for me to offer a clear path to a resolution. In the meantime, getting some video from you of the issue occurring may be helpful for our devs. Thanks.

Re: Game Doesn't Work

Posted: January 28th, 2021, 3:56 pm
by BulldawgTGR
A video for what? I turn the game on, the developer logos appear and then it freezes at the loading screen with the WASTELAND 3 image before it goes into the main menu. If I want to play this game then I have to play it factory issued because the 1.13 Update makes it freeze. The only reason I never returned this or exchanged it to begin with is because it was a gift. Is anyone else not able to play this on PS4?

Re: Game Freezes on PS4

Posted: April 6th, 2021, 3:28 pm
by Ulme
TL;DR: Yes absolutely unplayable.

"A little" late I guess, but just found this forum. Bought this near release on PS4 solely for coop with a friend. In the beginning we managed to play for about half an hour before it started freezing. On my screen (not hosting), no matter how many times we restarted, I would get an infinite spinner and the host would get some rubbish about my game taking too long and we got thrown out. Tried a few times, same result. Started over and did not get even that far into the game in subsequent attempts. We then decided to wait a few updates and hope for a more stable version. With the most recent update we started over, and in the very first combat when it's my turn to act, controllers are not responding so I cannot do anything. We tried loading our old save instead and the infinite spinner problem is still there.

Uninstalled the game, maybe we try again in a year or so. Super disappointed at the absolute rip off this game has turned out to be. If I pay premium price for a game, I would expect to be able to play it. These are no small glitches, it is 100% impossible to play.

We play other coop games frequently on the PS4 together and in no shape or form had any problems like this.