Anyone having problems with the PS4 version?

For all Wasteland 2 discussion that does not fit elsewhere, suggestions, feedback, etc. No spoilers allowed.

Moderator: Ranger Team Alpha

NinjaMoose
Initiate
Posts: 11
Joined: October 20th, 2015, 8:00 pm

Anyone having problems with the PS4 version?

Post by NinjaMoose » October 21st, 2015, 8:06 pm

I'm playing the DC on my PS4 and the game is great. Only problem is the game keeps force closing on me. Seems like it usually kicks me out if I'm playing for about 3 hours. Sometimes it closes after about 1 hour. At first I thought maybe it was my PS4 itself which was the problem but all my other games play fine. Anyone else having this problem or did I just luck out with a crappy disc or something?

vyvexthorne
Acolyte
Posts: 83
Joined: August 8th, 2012, 7:06 pm

Re: Anyone having problems with the PS4 version?

Post by vyvexthorne » October 22nd, 2015, 12:38 am

Crashing or just closing down to the main screen? I've had a few crashes and I get an error code.

NinjaMoose
Initiate
Posts: 11
Joined: October 20th, 2015, 8:00 pm

Re: Anyone having problems with the PS4 version?

Post by NinjaMoose » October 22nd, 2015, 12:45 am

It crashes and I get the error code. Seems to happen around 3 hours of game play mostly. Every once in awhile I happens shortly after I start playing the game

gallenmuur
Initiate
Posts: 21
Joined: October 22nd, 2015, 5:55 am

Re: Anyone having problems with the PS4 version?

Post by gallenmuur » October 22nd, 2015, 6:04 am

The game has crashed on me twice since I started playing on the PS4. It only happens during a load screen.

User avatar
Darkeus
Acolyte
Posts: 59
Joined: April 11th, 2012, 12:33 pm

Re: Anyone having problems with the PS4 version?

Post by Darkeus » October 22nd, 2015, 6:11 am

That sounds like the PS4 version has a memory leak.

gallenmuur
Initiate
Posts: 21
Joined: October 22nd, 2015, 5:55 am

Re: Anyone having problems with the PS4 version?

Post by gallenmuur » October 22nd, 2015, 6:16 am

Thank god for the quick save button. I have to do it every time there is a loading screen just to be safe.

User avatar
sear
Developer
Posts: 2574
Joined: March 21st, 2012, 8:30 am

Re: Anyone having problems with the PS4 version?

Post by sear » October 22nd, 2015, 8:28 am

Are you playing with the day one patch? If not, I'd highly recommend it. The other thing I can think of that might cause frequent crashes is a corrupt install or hard drive (or some other hardware issue).

gallenmuur
Initiate
Posts: 21
Joined: October 22nd, 2015, 5:55 am

Re: Anyone having problems with the PS4 version?

Post by gallenmuur » October 22nd, 2015, 8:54 am

sear wrote:Are you playing with the day one patch? If not, I'd highly recommend it. The other thing I can think of that might cause frequent crashes is a corrupt install or hard drive (or some other hardware issue).
I'm playing on the most recent PS4 update and it is not my HDD. I will try uninstalling and reinstalling the game tonight.

Demendred
Initiate
Posts: 20
Joined: March 7th, 2014, 7:11 am

Re: Anyone having problems with the PS4 version?

Post by Demendred » October 22nd, 2015, 9:36 am

It does that with me time to time. i have the patch installed. It happened a few times on a loading screen.
Matthias is my savior. He will make me into a perfect union of man and machine. I shall be part of a race of synthetic warriors whom will destroy those butchers in Arizona, and help bring a clean and perfect future to all corners of the world.

Bovrillor
Novice
Posts: 48
Joined: October 22nd, 2015, 3:03 am

Re: Anyone having problems with the PS4 version?

Post by Bovrillor » October 22nd, 2015, 9:45 am

Also getting a fair few crashes on PS4. Patch 1.1. Often happens when using 'quit to menu'.

Also extremely disappointed at the lack of character portraits on the console version. Without the 'snapshot' feature there is now a pathetic selection of character portraits, so much that I can't stand the appearance of my own squad :/

NinjaMoose
Initiate
Posts: 11
Joined: October 20th, 2015, 8:00 pm

Re: Anyone having problems with the PS4 version?

Post by NinjaMoose » October 22nd, 2015, 9:53 am

I'm getting the crashes at the loading screen as well. I have the patch installed. I'll try to uninstall, reinstall it and see what happens

Palegod
Novice
Posts: 49
Joined: October 18th, 2015, 10:43 am

Re: Anyone having problems with the PS4 version?

Post by Palegod » October 22nd, 2015, 11:18 am

sear wrote:Are you playing with the day one patch? If not, I'd highly recommend it. The other thing I can think of that might cause frequent crashes is a corrupt install or hard drive (or some other hardware issue).
Seems like a memory leak while loading to me. It's especially noticeable if you happen to be really annoyed with the way that breaking down weapons results in broken parts like 90+% of the time and decide to workaround it by save scumming every second weapon you break down. Load the game 10-20 times in a row trying to get the mod you want and it will usually crash during the process, or on one of the next few map transitions you make afterwards.

It happens just running around from location to location too, btw. Save scumming only speeds up the process in my experience.

(This the the patched version.)

Havel Tha Rock
Initiate
Posts: 12
Joined: October 21st, 2015, 10:57 am

Re: Anyone having problems with the PS4 version?

Post by Havel Tha Rock » October 22nd, 2015, 1:59 pm

Same here; I'm on PS4... The game crashes often (memory leaks on Xb1 exist too) + lots of bugs! Wait till your "dismissed" party members start disappearing from RC or progression stopper bugs appear... It's best to stop playing for now, as they *might* release a patch soon, smoothing things up!

NinjaMoose
Initiate
Posts: 11
Joined: October 20th, 2015, 8:00 pm

Re: Anyone having problems with the PS4 version?

Post by NinjaMoose » October 22nd, 2015, 4:29 pm

Yeah all my dismissed recruits disappeared on me. All I have left is Ralphy. I haven't had any progression stopping bugs but I've been having some minor bugs popping up like perks not unlocking when I meet the skill requirements and once in awhile when I engage in a combat encounter from the world map I can't exit the little battlefield map once the enemies are dead and have to reload a save. Where did you get stuck progression wise because of bugs?

Palegod
Novice
Posts: 49
Joined: October 18th, 2015, 10:43 am

Re: Anyone having problems with the PS4 version?

Post by Palegod » October 22nd, 2015, 4:38 pm

There are a couple doors that if you examine them instead of just opening, then the open command disappears. Only way past them is lockpick, explosives, or reloading your game. One of them is in the Citadel and blocks off half the game, and it's nearly impossible to pick or blow up, so realizing what happened and reloading your game while you still have a recent save is the only solution.

I realized it about 6 hours late... :/

gallenmuur
Initiate
Posts: 21
Joined: October 22nd, 2015, 5:55 am

Re: Anyone having problems with the PS4 version?

Post by gallenmuur » October 23rd, 2015, 5:08 am

Palegod wrote:There are a couple doors that if you examine them instead of just opening, then the open command disappears. Only way past them is lockpick, explosives, or reloading your game. One of them is in the Citadel and blocks off half the game, and it's nearly impossible to pick or blow up, so realizing what happened and reloading your game while you still have a recent save is the only solution.

I realized it about 6 hours late... :/
I can confirm the East gate in the Central Complex of the AG Center is this way. I had to reload to open it after examining it.

uv23
Initiate
Posts: 21
Joined: February 25th, 2014, 6:05 pm

Re: Anyone having problems with the PS4 version?

Post by uv23 » November 8th, 2015, 7:47 am

I have half a dozen crashes every play session, which always occur on game load.

Bovrillor
Novice
Posts: 48
Joined: October 22nd, 2015, 3:03 am

Re: Anyone having problems with the PS4 version?

Post by Bovrillor » November 10th, 2015, 5:26 am

uv23 wrote:I have half a dozen crashes every play session, which always occur on game load.
That's way more than I experience, have you tried reinstalling?

uv23
Initiate
Posts: 21
Joined: February 25th, 2014, 6:05 pm

Re: Anyone having problems with the PS4 version?

Post by uv23 » November 10th, 2015, 11:12 am

Bovrillor wrote:
uv23 wrote:I have half a dozen crashes every play session, which always occur on game load.
That's way more than I experience, have you tried reinstalling?
No. I haven't touched it since the citadel door bug locked me out of progressing. Maybe it'll be better post-patch.

NeonBlade
Initiate
Posts: 8
Joined: November 19th, 2015, 2:42 pm

Re: Anyone having problems with the PS4 version?

Post by NeonBlade » November 19th, 2015, 2:59 pm

So far I have had no issues with crashing, but I can confirm the Ranger(s) not returning to the Citadel and vanishing from the game world entirely is still occurring after the patch has been installed. La Roca and Rook have simply, ceased to exist.

I am attempting to remedy by uninstalling the game, downloading and updating before I start again. I also backed up my old save file on USB but I believe ( hoping really ), that it is not compromised with the faulty line code, as I started Wasteland before the patch came to PSN.

After it is finished I only have another 6 hours of download time to go :| I will try my original save file to see if the Rangers pop back up, but I'm not counting on it.

Which means I may have to begin from scratch considering I had substantial play time invested.


EDIT Just checking in to confirm, that after an delete/uninstall. Clean reinstall and update, and loading back on my old save file the Ranger Rook and La Roca are not in the Citadel. I left and reloaded the area, still not present.

It seems the faulty code is embedded into that save file itself, meaning it may be unsafe to use any further, which would cause more grief with other recruits.

Guess I start again. :cry:
Last edited by NeonBlade on November 20th, 2015, 4:16 am, edited 1 time in total.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests