low quality textures?

If you need assistance with a technical is sue with The Bard's Tale IV, this forum is for you. Spoilers are allowed, but spoiler warning tags are recommended.

Moderator: Bard Hall Bouncers

Post Reply
zambien
Initiate
Posts: 17
Joined: July 26th, 2018, 9:55 am

low quality textures?

Post by zambien » September 18th, 2018, 5:14 pm

Is it just me or did the graphics quality, especially facial textures go way way down with the release? I recall the faces looked better in the beta. Maybe I'm remembering wrong?

satoru
Novice
Posts: 35
Joined: June 2nd, 2015, 4:02 pm

Re: low quality textures?

Post by satoru » September 18th, 2018, 7:04 pm

what graphical setting are you using?

zambien
Initiate
Posts: 17
Joined: July 26th, 2018, 9:55 am

Re: low quality textures?

Post by zambien » September 19th, 2018, 6:42 am

Everything set to ultra.

User avatar
moss_icon
Initiate
Posts: 4
Joined: September 19th, 2018, 2:01 am

Re: low quality textures?

Post by moss_icon » September 19th, 2018, 7:50 am

I had this problem, sometimes the more detailed textures don't seem to load very quickly, or even at all. After one of the patches yesterday it got better.

User avatar
sear
Developer
Posts: 2679
Joined: March 21st, 2012, 8:30 am

Re: low quality textures?

Post by sear » September 19th, 2018, 12:30 pm

Due to the way texture streaming can work, sometimes the amount of free memory you have available can cause variation in the level of detail. The game will try to optimize the textures shown based on where you are looking and how much memory it has to work with.

Please let us know if you keep experiencing the issue, and I can definitely pass it up the chain for investigation.

User avatar
Nystrom
Acolyte
Posts: 70
Joined: May 16th, 2018, 4:45 am

Re: low quality textures?

Post by Nystrom » September 19th, 2018, 12:45 pm

I've seen similar issues, but I'm chalking it up to the fact I'm currently forced to play 2560x1440 at full screen, while the 3440x1440 doesn't work. I do play ultra as well except I did lower shadows to medium. Memory shouldn't be an issue for me, I have 24 GB of it and a decent 1080 EVGA card

User avatar
agris
Novice
Posts: 30
Joined: July 25th, 2012, 5:59 pm

Re: low quality textures?

Post by agris » September 20th, 2018, 6:04 pm

These suggestions dramatically improved how my game looked, fixed the popping shadows, and the textures are sharp as hell with the sharpen tweaks.

some background, before the tweaks, from here:
BTW, in that same folder where Engine.ini is located (AppData/BT4/Config/WindowsNoEditor) you'll also find the general Options file for the game called GameUserSettings.ini. You can enable/disable all of the shit in there and then set it to READ-ONLY as well.

Numerical values for main settings are always 0-3, with 0 being None/Low, 1 being Medium, 2 being High and 3 being "Ultra".

One thing I noticed when I first opened GameUserSettings was that for whatever fucked up reason Textures was set to "1" even though I'd selected High in the game. Changing the numerical value and then setting the file READ-ONLY seems to have made it "stick".

EDIT: Antialiasing values are 0 (none), 1 (FXAA) and 2 (Temporal AA). The ScreenPercentage setting is also in this file and you can go above 100 if you want and have the rig for it... maximum is 200% which would be 4k if you use 1080p.

Also always, always lower ScreenResolutionPercentage instead of lowering your actual Display Resolution for the game, it's much better. Lowering your real resolution affects everything including 2D elements like the UI but lowering ScreenPercentage does not.

If you find everything looks too blurry check to make sure you don't have Temporal AA enabled, and if you want to use it without the blurry filter then use ReShade lumasharpen on top. (ed: this is addressed in a later quote, you can fix the foggy look with some simple .ini tweaks)

Keep textures high resolution, force the game to remember your settings, and remove shadow and LOD pop-in effects - all here:
I'll do the people who actually really want to play this a solid...

- Paste the following on the game's Engine.ini file if you want to:

1. Ensure textures are always at 'High' quality.
2. Ensure shadows are always drawn correctly.
3. Eliminate all texture pop-in (i.e. fix the LoDs).
4. Get a bit better performance, though this isn't a "performance tweak" by any means, just universally good settings for the UE4.

Go to your AppData/BardsTale4/Config/WindowsNoEditor and open the Engine.ini file and replace its contents with the following:

[Core.System]
Paths=../../../Engine/Content
Paths=%GAMEDIR%Content
Paths=../../../BardsTale4/Plugins/MORT/Content
Paths=../../../BardsTale4/Plugins/RamaSaveSystem/Content
Paths=../../../Engine/Plugins/Tests/EditorTests/Content
Paths=../../../Engine/Plugins/Tests/RuntimeTests/Content
Paths=../../../BardsTale4/Plugins/VaTexAtlas/Content
Paths=../../../BardsTale4/Plugins/WalkabilityVisualiser/Content
Paths=../../../Engine/Plugins/2D/Paper2D/Content
Paths=../../../Engine/Plugins/Media/MediaCompositing/Content
Paths=../../../Engine/Plugins/Runtime/AppleARKit/Content
Paths=../../../Engine/Plugins/Wwise/Content

[SystemSettings]
r.Streaming.PoolSize=1750 ; game default = 1500
r.Streaming.MaxTempMemoryAllowed=40 ; game default = 40
r.Streaming.FullyLoadUsedTextures=0 ; game default = 0
r.Streaming.FramesForFullUpdate=5 ; game default = 5
r.Streaming.HLODStrategy=0 ; forces all LOD mips to be loaded rather than streamed. game default = 0
r.UseShaderCaching=0 ; game default = 0
r.UseShaderPredraw=0 ; game default = 0
r.OptimizeForUAVPerformance=0 ; optimize for performance instead of memory. game default = 0 (optimizes for memory instead)
a.URO.ForceInterpolation=0 ; game default = 0
a.URO.ForceAnimRate=0 ; 1 = 30fps, 2 = 60fps? game default = 0
r.ViewDistanceScale=1.0 ; increase render distance. game default = 1
r.SkeletalMeshLODBias=-1 ; increase character LODs. game default = 0
r.StaticMeshLODDistanceScale=1.0 ; increase static mesh LOD distances, lower = larger distance. game default = 1
r.DetailMode=2 ; ensures materials and objects are rendered at full quality
foliage.DensityScale=0.80 ; game default = 1
grass.DensityScale=0.80 ; game default = 1
foliage.LODDistanceScale=0.80 ; increase grass LOD distance, not much perf impact. game default = 1
foliage.MinInstancesPerOcclusionQuery=1024 ; game default = 256, but UE4 recommended is 1024-65536
r.MaxAnisotropy=16 ; game default = 8
r.Tonemapper.Sharpen=0.75 ; game default = 0
r.LightFunctionQuality=1 ; game default = 1
r.Shadow.DistanceScale=0.80
r.Shadow.CSM.TransitionScale=0.80
r.ShadowQuality=5
r.Shadow.CSM.MaxCascades=2 ; above 3 doesn't seem to make any difference, try lowering it if you like. game default = 10
r.Shadow.MaxResolution=1024 ; anything higher than 4096 is placebo, best performance with 2048. game default = 2048
r.Shadow.RadiusThreshold=0.040 ; lower value = further shadow distance. game default = 0.03
r.MinScreenRadiusForLights=0.030 ; game default = 0.03
r.MinScreenRadiusForSmallLights=0.010 ; game default = 0.01
r.MotionBlurQuality=4
r.MotionBlur.Amount=0.3
r.MotionBlur.Max=1
r.MotionBlur.Scale=1
r.MotionBlurSeparable=1
r.AmbientOcclusionLevels=2
r.AmbientOcclusionRadiusScale=1.5
r.DepthOfFieldQuality=2
r.SceneColorFringeQuality=1
r.LensFlareQuality=2
r.EyeAdaptationQuality=2
r.BloomQuality=5
r.FastBlurThreshold=7
r.Upscale.Quality=3
r.Tonemapper.GrainQuantization=1

Enjoy. This fixed all of the pop-in and the glitchy shadows for me, as well as ensures that the textures don't change shapes/qualtiy levels. also you can play around with the values for LODs and foliage and all that stuff for less/more performance/quality.

EDIT: Remeber to make the file READ-ONLY afterwards!
Tweaks to keep the game and textures looking sharp with temporal, here:
If you're using the game's Temporal AA then I just found out you don't need to enable ReShade, instead you can use UE4's built-in sharpener settings:

- Add the following to the Engine.ini under the [SystemSettings]

r.Tonemapper.Sharpen=1.25 ; game default = 0
r.TemporalAASharpness=1.25 ; game default = 0
I use 1.20 fwiw, and if you aren't using temporal AA, I believe the Tonemapper set to 1.20-ish still helps the textures look sharp without being too intense.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest