Page 1 of 1

Bug: Issues with fist attack

Posted: March 3rd, 2017, 7:11 pm
by DDD
Save a game BEFORE selecting a doppleganger in the mirror. Exit the game, start it again and load the savegame. Proceed in the character creation etc. Once the first crisis with the Sorrow begins, Last Castoff always does only 1 point of damage, regardless of the amount of effort put into the attack. This problem occurs also later in Sagus Cliffs.

EDIT: No, the issue does not just happen to Last Castoff in prologue. The problem just occurred to me with Aligern during the crisis with Quoro (after unequipping his mace). His fists just do 1 damage, even if you put max effort into the attack. The statistics also always show 1+0 on the attack effort selection "dialogue".

https://github.com/tton-bugs-hunters/tt ... r/issues/7

Re: Bug: Issues with fist attack

Posted: March 4th, 2017, 3:25 am
by vv221
I confirm this, first time I tried the prologue (without loading a saved game) Effort would add bonus damage to unarmed attacks, while the next time I tried it (loading a saved game in the process) Effort would increase the chance to hit but not the damage.

Debian Sid amd64, GOG version

Re: Bug: Issues with fist attack

Posted: March 4th, 2017, 3:29 am
by DDD
Yes. I think I know exactly when the problem manifests and how to work around it:
  • Unequip any character's weapon

    Save

    Load the game

    Enter crisis - the problem occurs

    Load thje game again

    Equip and unequip any weapon

    Enter crisis - effort works correctly

Re: Bug: Issues with fist attack

Posted: March 29th, 2017, 8:30 pm
by JoelofDeath
Bumping this topic cause it's still a bug after patch 1.02.

My experience:
When loading a game with an unarmed (or just using claws) PC, effort bonus damage is not applied.

In order to make it work properly, you have to:
1. load game
2. equip random weapon (so not unarmed)
3. unequip weapon
4. effort now applies damage on unarmed attacks correctly.

It's a bit tiresome to do this after every load though.

Note that this bug is very consistent, it occurs after every load. So should be easy to track down.

Re: Bug: Issues with fist attack

Posted: March 30th, 2017, 5:54 pm
by sear
This is a known issue - it appears to be caused by loading a save near the start, rather than starting a brand-new game.

Note from our QA guys:
Further investigation revealed that this issue does not occur when player chooses Glaive class, additionally equipping and unequipping any weapon resolves this issue in currently played session.