[Linux/Steam] Sound issues: Laggy, only on one ear, and unusually quiet.

If you need assistance with a technical issue, this forum is for you. Specifically for help with Torment: ToN itself. Spoilers are allowed, but spoiler warning tags are recommended.

Moderator: Memovira Goons

Post Reply
User avatar
sam2s
Initiate
Posts: 13
Joined: April 9th, 2013, 6:06 am

[Linux/Steam] Sound issues: Laggy, only on one ear, and unusually quiet.

Post by sam2s » February 28th, 2017, 12:49 pm

I tried out the Steam version of the game on 64-bit Linux, while waiting for an opportunity to switch it for a GOG.com key... and experienced multiple sound-related issues right from the start:

1) Lag:
When I click a button in the game menu, the button-clicking sound effect plays maybe half a second later, rather than simultaneously. Pretty annoying.

2) Left ear only:
The game only seems to send sound to the left speaker of my headphones, the right one stays silent. In other Steam games on the same computer, sound works fine.

3) Low volume:
The sound is also really quiet. I had to turn my system volume to 100% and all in-game volume sliders to 100%, to be able to properly hear the sound effects. In other Steam games, turning up the sliders so high would be utterly ear-destroying.

4) No voice-over.
The narration at the start of the game was supposed to be voiced, wasn't it? That seems to be missing completely, for me. Callistege and Aligern don't have voice-over either. Selection sounds (e.g. "I'm ready") do play, but sound like they're muffled and have excessive reverb.

shmerl
Acolyte
Posts: 84
Joined: September 28th, 2014, 6:31 pm

Re: [Linux/Steam] Sound issues: Laggy, only on one ear, and unusually quiet.

Post by shmerl » February 28th, 2017, 12:52 pm

Distro / system configuration would be helpful. Also, check $HOME/.config/unity3d/InXile Entertainment/Torment/Player.log

User avatar
sam2s
Initiate
Posts: 13
Joined: April 9th, 2013, 6:06 am

Re: [Linux/Steam] Sound issues: Laggy, only on one ear, and unusually quiet.

Post by sam2s » February 28th, 2017, 1:00 pm

Distro is Arch Linux.
The sound system used is ALSA version 1.1.3 (no PulseAudio).

Code: Select all

Computer Information:
    Manufacturer:  Unknown
    Model:  Unknown
    Form Factor: Desktop
    No Touch Input Detected
    
Processor Information:
    CPU Vendor:  AuthenticAMD
    CPU Brand:  AMD Phenom(tm) II X4 965 Processor
    CPU Family:  0x10
    CPU Model:  0x4
    CPU Stepping:  0x3
    CPU Type:  0x0
    Speed:  3400 Mhz
    4 logical processors
    4 physical processors
    HyperThreading:  Unsupported
    FCMOV:  Supported
    SSE2:  Supported
    SSE3:  Supported
    SSSE3:  Unsupported
    SSE4a:  Supported
    SSE41:  Unsupported
    SSE42:  Unsupported
    AES:  Unsupported
    AVX:  Unsupported
    CMPXCHG16B:  Supported
    LAHF/SAHF:  Supported
    PrefetchW:  Unsupported
    
Network Information:
    Network Speed:  
    
Operating System Version:
    Linux (64 bit)
    Kernel Name:  Linux
    Kernel Version:  4.10.1-1-ARCH
    X Server Vendor:  The X.Org Foundation
    X Server Release:  11901000
    X Window Manager:  KWin
    Steam Runtime Version:  steam-runtime-beta-release_2016-12-05
    
Video Card:
    Driver:  X.Org Gallium 0.4 on AMD REDWOOD (DRM 2.49.0 / 4.10.1-1-ARCH, LLVM 3.9.1)

    Driver Version:  3.0 Mesa 17.0.0
    OpenGL Version: 3.0
    Desktop Color Depth: 24 bits per pixel
    Monitor Refresh Rate: 60 Hz
    VendorID:  0x1002
    DeviceID:  0x68d8
    Revision Not Detected
    Number of Monitors:  1
    Number of Logical Video Cards:  1
    Primary Display Resolution:  1920 x 1080
    Desktop Resolution: 1920 x 1080
    Primary Display Size: 18.78" x 10.55"  (21.54" diag)
                                            47.7cm x 26.8cm  (54.7cm diag)
    Primary VRAM: 1024 MB
    
Sound card:
    Audio device: VIA VT1718S
    
Memory:
    RAM:  7987 Mb
    
Miscellaneous:
    UI Language:  English
    LANG:  en_US.UTF-8
    Microphone:  Not set
    Steam Controller Cable and Base:  Not set
    Total Hard Disk Space Available:  112421 Mb
    Largest Free Hard Disk Block:  40616 Mb
    VR Headset: None detected
Player.log is here: http://pastebin.com/raw/RG6SQRQh
Last edited by sam2s on March 1st, 2017, 6:02 am, edited 5 times in total.

shmerl
Acolyte
Posts: 84
Joined: September 28th, 2014, 6:31 pm

Re: [Linux/Steam] Sound issues: Laggy, only on one ear, and unusually quiet.

Post by shmerl » February 28th, 2017, 1:07 pm

For a test, I'd try it with pulseaudio, and see if stuttering still exists.

User avatar
sam2s
Initiate
Posts: 13
Joined: April 9th, 2013, 6:06 am

Re: [Linux/Steam] Sound issues: Laggy, only on one ear, and unusually quiet.

Post by sam2s » June 25th, 2017, 9:19 am

All of these issues seem to be fixed in patch 1.1.0.
Hooray!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests