screen tearing in full screen (linux version)

If you need assistance with a technical issue, this forum is for you. Specifically for help with Wasteland 2 itself. Spoilers are allowed, but spoiler warning tags are recommended.
Post Reply
reiam
Initiate
Posts: 4
Joined: September 23rd, 2014, 4:29 pm

Hi,
Looks like vsync doesn't work in full screen mode and there's a lot of screen tearing that doesn't exist in window mode.
Is there a fix or workaround available for linux version?

Ubuntu 14.04
Nvidia proprietary drivers 331.38
randir14
Explorer
Posts: 443
Joined: March 15th, 2012, 5:04 pm

Try forcing the game to run in DX9 mode, vsync is broken in the default DX11 renderer. Add this line to your launch options in Steam: -force-d3d9
reiam
Initiate
Posts: 4
Joined: September 23rd, 2014, 4:29 pm

Yes, but since linux uses opengl rendering, that didn't help.
User avatar
Thomas_inXile
Developer
Posts: 2910
Joined: March 5th, 2012, 1:26 pm
badge image for 4o80c0.png

We're aware of the issue but have not found a work-around or fix, sorry. Any feedback on it from the Linux community would be most welcome.
Thomas Beekers
Creative Producer
reiam
Initiate
Posts: 4
Joined: September 23rd, 2014, 4:29 pm

Ok, thanks for the response.
kilobug
Adventurer
Posts: 985
Joined: September 21st, 2014, 1:07 am
badge image for 3rz1is.png
badge image for ijw2ib.png
badge image for wl3badge.png

It seems on my setup (Radeon HD6850 using the Mesa free drivers) that I managed to remove the tearing by adding

Code: Select all

Option      "EXAVSync" "on"
in my

Code: Select all

/etc/X11/xorg.conf
file. If you don't have the file, just create it with :

Code: Select all

Section "Device"
        Identifier  "Radeon"
        Driver      "radeon"
        Option      "EXAVSync" "on"
EndSection
I don't know if it works with other cards/drivers (since it's an EXA settings, it probably won't work with cards using glamor like the radeonsi ones), nor if the same effect can be achieved from within the game, without having to change global X settings.
tomtom
Initiate
Posts: 6
Joined: September 20th, 2014, 2:21 am

I just found a solution that is working for me.

I turned off "Unredirect Fullscreen Windows" in Compiz (Ubuntu 14.04, unity desktop environment). You can do that by using "ccsm" (Compiz Settings Manager). Go to "General > Composite" and uncheck "Unredirect Fullscreen Windows". After doing this, Wasteland 2 fullscreen performance was the same as windowed mode performance.

The funny thing is that enabling this setting should actually _improve_ your full screen gaming frame rate and enabling reliable vsync in fullscreen video playback. But it seems to break vsync in Unity3D based games.

Also have a look at: http://askubuntu.com/questions/99228/do ... nce-for-vi

Using "gconftool-2" did not work for me. Just be careful with ccsm (read: http://askubuntu.com/questions/80589/wh ... o-avoid-it).
reiam
Initiate
Posts: 4
Joined: September 23rd, 2014, 4:29 pm

Thanks tomtom, that worked for me too.
andrei9473
Initiate
Posts: 1
Joined: August 4th, 2021, 7:06 am

If you are on KDE Plasma

Compositor -- System Settings
Display Configuration
Allow applications to block compositing ( uncheck the checkbox )

worked fine for me
Post Reply

Return to “Wasteland 2: Technical Help”