Wasteland 2: now with improved modding capabilities (and bugfixes!)

For community content (fan-art, fanfic, etcetera) for Wasteland 2.
Post Reply
Executor_
Explorer
Posts: 400
Joined: August 11th, 2014, 5:38 am

Could you post the contents of the log file please? It can be found in the following locations:

Windows
location: Steam\steamapps\common\Wasteland 2 Director's Cut\Build\WL2_Data
file: output_log.txt

Mac
location: Macintosh HD -> Users -> USERNAME -> Library -> Logs -> Unity
file: Player.log

Linux
location: ~/.config/unity3d/inXile Entertainment/Wasteland2DC:Director's Cut/
file: Player.log


Also, did you try running the game with the base, unmodified DLL? Did the same black screen occur?
trentcorwin
Initiate
Posts: 3
Joined: December 18th, 2022, 7:29 pm

Hi Executor -- I can get the game to run using a vanilla setup. Problem only occurs once new DLL is copied in. I will post both a Vanilla startup log and a log with the DLL replaced.

DLL Replaced Logfile:

Initialize engine version: 4.5.5f1 (7684ad0c5a44)
GfxDevice: creating device client; threaded=1
Direct3D:
Version: Direct3D 11.0 [level 11.0]
Renderer: NVIDIA GeForce RTX 2060 (ID=0x1f11)
Vendor: NVIDIA
VRAM: 3072 MB
Begin MonoManager ReloadAssembly
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\UnityEngine.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\UnityEngine.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-CSharp-firstpass.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-CSharp.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-CSharp.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-UnityScript-firstpass.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-UnityScript-firstpass.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-UnityScript.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-UnityScript.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\DecalSystem.Runtime.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\DecalSystem.Runtime.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Hayate.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Hayate.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\SteamworksManaged.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\SteamworksManaged.dll into Unity Child Domain
- Completed reload, in 0.059 seconds
<RI> Initializing input.

<RI> Input initialized.

desktop: 1920x1080 60Hz; virtual: 1920x1080 at 0,0
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\System.dll (this message is harmless)
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\System.Core.dll (this message is harmless)
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\UnityScript.Lang.dll (this message is harmless)
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Boo.Lang.dll (this message is harmless)
TypeLoadException: Could not load type 'UIPanel' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

TypeLoadException: Could not load type 'UIPanel' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

TypeLoadException: Could not load type 'UIPanel' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

TypeLoadException: Could not load type 'UIPanel' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

TypeLoadException: Could not load type 'SpringPanel' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

TypeLoadException: Could not load type 'LevelBounds' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

TypeLoadException: Could not load type 'UnityEngine.Color32' from assembly 'UnityEngine, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

TypeLoadException: Could not load type 'UnityEngine.Color32' from assembly 'UnityEngine, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

TypeLoadException: Could not load type 'UnityEngine.Color32' from assembly 'UnityEngine, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

TypeLoadException: Could not load type 'UIPanel' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

TypeLoadException: Could not load type 'UIDragScrollView' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

TypeLoadException: Could not load type 'PolygonRevealer' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

TypeLoadException: Could not load type 'PolygonRevealer' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

TypeLoadException: Could not load type 'LevelBounds' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


(Filename: Line: -1)

A script behaviour has a different serialization layout when loading. (Read 24 bytes but expected 36 bytes)
Did you #ifdef UNITY_EDITOR a section of your serialized properties in any of your scripts?

(Filename: Line: 1170)

A script behaviour has a different serialization layout when loading. (Read 24 bytes but expected 36 bytes)
Did you #ifdef UNITY_EDITOR a section of your serialized properties in any of your scripts?

(Filename: Line: 1170)

A script behaviour has a different serialization layout when loading. (Read 24 bytes but expected 36 bytes)
Did you #ifdef UNITY_EDITOR a section of your serialized properties in any of your scripts?

(Filename: Line: 1170)

WARNING: Shader Unsupported: 'Hidden/TerrainEngine/BillboardTree' - Pass '' shader state not supported
Shader 'Wasteland2/Melt': fallback shader 'BumpedSpecular' not found
A script behaviour has a different serialization layout when loading. (Read 32 bytes but expected 48 bytes)
Did you #ifdef UNITY_EDITOR a section of your serialized properties in any of your scripts?

(Filename: Line: 1170)

MissingMethodException: Method not found: 'UnityEngine.Object.Instantiate'.

UnityEngine.MonoBehaviour:StartCoroutine_Auto(IEnumerator)
UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
LogoLauncher:Update()

(Filename: Line: -1)



Vanilla Startup

Initialize engine version: 4.5.5f1 (7684ad0c5a44)
GfxDevice: creating device client; threaded=1
Direct3D:
Version: Direct3D 11.0 [level 11.0]
Renderer: NVIDIA GeForce RTX 2060 (ID=0x1f11)
Vendor: NVIDIA
VRAM: 3072 MB
Begin MonoManager ReloadAssembly
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\UnityEngine.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\UnityEngine.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-CSharp-firstpass.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-CSharp.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-CSharp.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-UnityScript-firstpass.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-UnityScript-firstpass.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-UnityScript.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Assembly-UnityScript.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\DecalSystem.Runtime.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\DecalSystem.Runtime.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Hayate.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Hayate.dll into Unity Child Domain
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\SteamworksManaged.dll (this message is harmless)
Loading D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\SteamworksManaged.dll into Unity Child Domain
- Completed reload, in 0.058 seconds
<RI> Initializing input.

<RI> Input initialized.

desktop: 1920x1080 60Hz; virtual: 1920x1080 at 0,0
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\System.dll (this message is harmless)
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\System.Core.dll (this message is harmless)
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\UnityScript.Lang.dll (this message is harmless)
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\Boo.Lang.dll (this message is harmless)
Platform assembly: D:\Steam\steamapps\common\Wasteland 2\Build\WL2_Data\Managed\System.Xml.dll (this message is harmless)
WARNING: Shader Unsupported: 'Hidden/TerrainEngine/BillboardTree' - Pass '' shader state not supported
Shader 'Wasteland2/Melt': fallback shader 'BumpedSpecular' not found
WARNING: Shader Unsupported: 'Hidden/CameraMotionBlurDX11' - Pass '' shader state not supported
WARNING: Shader Unsupported: 'Hidden/CameraMotionBlurDX11' - Setting to default shader.
WARNING: Shader Unsupported: 'Hidden/Nature/Tree Creator Leaves Optimized' - Pass '' shader state not supported
Wasteland2 version is 65562

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

The referenced script on this Behaviour is missing!

(Filename: Line: 1783)

UnloadTime: 2.475200 ms
Unloading 5 Unused Serialized files (Serialized files now loaded: 8 / Dirty serialized files: 0)

Unloading 202 unused Assets to reduce memory usage. Loaded Objects now: 11268.
Total: 7.366700 ms (FindLiveObjects: 0.430900 ms CreateObjectMapping: 0.777900 ms MarkObjects: 5.224100 ms DeleteObjects: 0.572600 ms)

Executor_
Explorer
Posts: 400
Joined: August 11th, 2014, 5:38 am

My patch is only for the Director's Cut version of the game. I should've made that clearer in the original post. Updated it now.
trentcorwin
Initiate
Posts: 3
Joined: December 18th, 2022, 7:29 pm

Y'know what's terrible? I always thought I had the Director's Cut BECAUSE the art on the header in Steam shows "Wasteland 2 Director's Cut". Like, all the art associated with the non-director's cut on Steam says "Director's Cut" on it. So I just always assumed I had that! Ridiculous. I didn't figure it out until you said that just now, searched the Steam store and saw "Wasteland 2" and "Wasteland 2: Director's Cut" and Director's Cut is not in my library. Same art for both products. Ohhhhh boy, well, don't I feel a fool.

Sorry for the bother.
Ashestoashesjc
Initiate
Posts: 1
Joined: December 24th, 2022, 11:59 am

Hey, all. I'm playing Wasteland 2 Director's Cut that I bought on GOG. I'm using the Patchwork Free Camera Mod and the enhanced zoom part of the patch works fine but the Free Combat part of the mod where you retain control of the camera, even during enemy turns, doesn't.

Has anyone encountered this issue? Is it because I'm using the GOG version?
Executor_
Explorer
Posts: 400
Joined: August 11th, 2014, 5:38 am

My patched DLL shouldn't have any problems with the GOG. Are you sure the "Free Combat Camera" option is checked off in the Gameplay Options menu? Because I just re-tested it and it worked fine.
Ashestoashesjc
Initiate
Posts: 1
Joined: December 24th, 2022, 11:59 am

Executor_ wrote: December 25th, 2022, 3:31 am My patched DLL shouldn't have any problems with the GOG. Are you sure the "Free Combat Camera" option is checked off in the Gameplay Options menu? Because I just re-tested it and it worked fine.
Okay, it's working fine now that I've used one of your updated DLLs, rather than the version from Nexus. Thanks!
Last edited by Ashestoashesjc on December 25th, 2022, 9:50 am, edited 4 times in total.
apoc_now
Initiate
Posts: 14
Joined: April 21st, 2021, 2:43 am

I've sent you an email. Hopefully doesn't sound too complex.
Post Reply

Return to “Wasteland 2: Community Content”